Tables not created while installing Issue Tracker

5 years 2 months ago #1 by tmartin3000
Hello,

I would like to request a little help here.

I wanted to install Issue Tracker 1.6.3 on Joomla 3.3.3. However, when using the Extension Manager to upload and install the zip file, I get an Error 1146: (prefix)_it_people table doesn't exist.

I checked phpMyAdmin, and it looks like the database tables aren't created. I'm not sure if this has to do with the extension, or my server settings. I could install other Joomla extensions without problem, their respective database table entries were all created.

Could anyone please help me solve this issue? I'd appreciate it if someone could send me at least a description of what tables need to be created, I could do that manually.

Thanks in advance.

Please Log in or Create an account to join the conversation.

5 years 2 months ago #2 by geoffc
Not sure why its objecting to the table not existing. On a fresh install it should be creating them anyway. It's almost as if it thinks its performing an upgrade for some reason.

The SQL that gets executed on an install is located in the zip in the directory admin/sql and the file is named install.mysql.utf8.sql.

Never seen the 1146 error message on a fresh install, only where a previous install has failed for some reason, and I must have performed hundreds of installs of the component. Might be worth using myPHPadmin to see if there are any entries in the #__extensions table and if there are any #__it_?????? tables created..

Regards
Geoff
The following user(s) said Thank You: tmartin3000

Please Log in or Create an account to join the conversation.

5 years 2 months ago #3 by tmartin3000
Thank you for the quick response. What had happened seem to be what you have suspected: for some reason the first install failed, and subsequent installs were performed as if they were trying to update the existing incomplete installation.

I solved it by uninstalling already installed Issue Tracker components and removing their entries from #__extensions table. Then I reinstalled it and works like a charm now. :)

Thank you very much for taking the time to help me out.
The following user(s) said Thank You: geoffc

Please Log in or Create an account to join the conversation.

5 years 2 months ago #4 by geoffc
Thank you for updating us with your resolution.

We hope you find the component satisfactory for your needs..

Regards
Geoff

Please Log in or Create an account to join the conversation.

Time to create page: 0.267 seconds
Go To Top

The Macrotone Consulting Web site would like to use cookies to store information on your computer, to improve our website. Cookies used for the essential operation of the site have already been set. To find out more about the cookies we use and how to delete them, see our Privacy Policy.

I accept cookies from this site.